aansluiting nieuwe radio met originele kabels

ahoi iedereen,
ik heb met ombouwkit een nieuwe sony radio cd speler ingebouwd. Ziet er echt strak uit en de verlichting van het onderste deel van mijn dashboard is een stuk beter met het nieuwe paneel. Ik kwam er met het installeren wel achter dat er geen verloopstuk te krijgen is in Nederland voor de aansluiting die nu uit mijn Corsica komt (en die rechtstreeks op originele Delco-radio past) naar een standaard ISO aansluiting die aan mijn nieuwe radio gekoppeld is.
De enige mogelijkheid was dus handmatig per draadje te verbinden met de radio. Ik ben toen nagegaan welke kabeltjes naar welke speakers lopen en heb die kleuren gekoppeld aan de juiste kleuren van de nieuwe radio. Het vreemde was toen dat ik na het aansluiten van de speakers (8 kabeltjes, 4 speakers x min/plus) nog 5 kabeltjes vanuit de auto over had: terwijl ik er mijns inziens nog maar 3 moest gebruiken; de constante voeding, de geschakelde voeding en de aarde. Op de autoradio zat verder alleen nog een (blauwe) kabel voor de elektrische antenne maar mijn corsica heeft een vaste dus die heb ik niet aangesloten. Ik heb toen maar voor de meest logische kleuren gekozen voor aansluiting op die drie kabeltjes van de radio.
Toen ik daarna probeerde of ie het deed deden de speaker linksvoor en rechtsachter het wel maar linksachter deed het niet en rechtsvoor stoorde. Ik heb toen rechtsvoor een nieuw speakersnoertje naar het speakertje gelegd en toen deed die het ook. Ondertussen leek het of de constante voeding niet goed was want de radio onthield de ingestelde tijd en opgeslagen voorkeurzenders niet. Het meest vreemde was dat toen ik de speaker linksachter loskoppelde omdat ie het toch niet deed de hele radio niet meer aanging!
Ik heb toen nieuw speakersnoertje gelegd naar linksachter maar toen die was aangesloten deed heel de radio het nog steeds niet. Toen dacht ik dat ik misschien per abuis de stroomkabels op de linkerachterspeaker had aangesloten en de speakerkabel op de stroom van de radio maar toen ik deze had omgewisseld deed de radio het nog steeds niet.
Ik snap er nu echt niet veel meer van, ben niet super technisch maar zo’n autoradio is toch ook geen hogere wiskunde.
Wie kan mij helpen met wat ik fout heb gedaan en waar dit aan kan liggen?

Weet iemand welke kleuren voor wat staan?

Ik hoor het graag!